Subscribed unsubscribe Subscribe Subscribe

ruby 1.9系向けにruby gnome2 をビルドしてインストーラをつくってみた(適当)

ruby

ruby 1.9系にそろそろ移行しようと思いながらもruby gnome2がないとねということで、
ruby 1.9系でruby gnome2をビルドしてみることにした。

ruby-gnome2のMLでもWindows版はちょっと話題になっていたので試してみたというのもあります。

作業のベースにしたのはやはり以下のURLの内容です。感謝。
http://d.hatena.ne.jp/luna_8bit/20090321

途中経過を書こうかと思ったけど面倒臭くなってしまったので略。

  • rumix(ruby 1.9系)をインストール済みを前提としています。
  • svn HEADのr3758です
  • ちゃんとパッケージングしてません。
  • うまくうごかなくても怒らない。

成果物のインストーラであるruby-gnome2-0.19.3-r3758-20100410-i386-mswin32.exeはこちらに置いてみました。

http://gigo-ice.org/script/ruby/gnome2-unstable/index.ja.html